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Module  & Report Assignments

Modules Assignments
-Base Data Information 

Residential Room Management 
-Student Enrollment 

Residency Management 
-Student Registration 

Registration Residency Management 
-System Administrator

-Room Codes Management 
Suggested Administrator Reports

-Base Data Information 
Available Bed List 
Occupied Bed List 
Residency Room List 
Residential Room History 
Residential Room View 

-Student Enrollment 
Enrolled Student Room List 

-Student Registration 
Registration Student Room List 

-System Administrator 
Residency Codes List 

What we’ll Learn…..

Base Data: Room Codes Management 
-Special Needs Residential Room Management   
Base Data Pre-requisite 

-Room criteria established here 
Residential Rooms Management

-Room Tab
-Status Tab
-View Tab

Registration Residency  Management
-Assign 
-Un-Assign
-History

Residency  Management
-Assign 
-Un-Assign
-Temporary Interruption Tab
-History

Reporting
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Getting Started

Double click > Modules > Double Click
System Administrator> Click Rooms Code Management

The Residential Rooms Management functionality in 
Classmate allows users to setup rooms, establish 
room equipment needs, bed assignments, etc. This 
functionality can be accessed from both the 
registration and enrollment modules. Additionally, 
ClassMate users can also flag students that have 
temporary service interruptions & re-instatements.
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Room Codes
Rooms codes are created and can be customized for use in drop down menus in this module. It is
important that you are entering the item in the correct category so it will display in the proper
dropdown menu. Category Options include:

Room Features
Room Identifier
Room Types
Room Assignment Reasons 
Room Un-assign Reasons
Temporary Interruption Reason
Room Unavailable Reason
Bed Locations
Mobile Equipment

Helpful Hint: Each category has an associated ID range. This 
controls which drop down menu the item will display.
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Room Codes

To create a new room code . Use the following steps:
Select the Room Code Category . For example; Room Features (101-199). Selecting the category will allow 
the ID number to be generate within the correct ID range.
Select the Grey GREEN arrow button to create the next available unique ID number. 
Enter the Description in the Description field.
Select the “Save” icon to save the entry

Helpful Hint: Code with * are considered “Reserved Codes” and cannot be edited or 
deleted by users. 
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Getting Started

Double click > Modules > Double Click
Base Data> Click Residential Rooms Management

The Residential Rooms Management Module in 
Classmate allows users to setup residential 
rooms, establish equipment needs, bedding 
arrangements, etc. Additionally, the module will 
display the room status and visual view of the 
room with student photos. This module is to be 
used for residential rooms only. 

Helpful Hint: ONLY the residential rooms are to be setup in 
this module. Classrooms are setup up in 

Campus/Location/Building/Rooms Module. 
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Room Setup

Location: Select the Location by double clicking  on the name  or click the “+” sign to the left of the
location name 

Building: Select the Building by clicking  on the name  or click the “+” sign to the left of the
building name 

Room: Select the Room by clicking on the room 
name

Helpful Hint: Rooms displayed in RED font are currently 
suspended from use. 
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Rooms Tab
The Rooms Tab in Residential Room Management contains the following fields that need to be
populated prior to students being assigned into them.

*Room ID (6 Digit 
Alpha/Numeric)

*Room Name
*Room Type 
Room Identifier
Room Dimensions
Room Notes
*Beds ( Number of beds 
& Bed Location)
Room Occupancy
Room Status & Expected 
Return
Room Features
Mobile Equipment

Helpful Hint: Fields with an * are Mandatory and must be 
populate to  save a room entry.
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Status Tab (Removing a room from service)
The Status Tab in Residential Room Management is used to remove a room from service. Once a room is
unavailable, the room will display in RED on the rooms tab. To remove a room from service perform the following
steps: 

Select the Unavailable radio button. Mandatory field
Select a Reason. Mandatory field
Enter a Comment
Enter an Expected Return to service date
Select the Black “Save” icon to save the entry

Helpful Hint: If students are assigned to a room, you will not be able to 
remove it from service until students have been unassigned.
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Status Tab (Returning a room to service)
The Status Tab in Residential Room Management is also used to return  a room to service after it has been
suspended. Once a room is available it will display on the rooms tab in Black. To return  a room to service
perform the following steps: 

Select the Available radio button. Mandatory field
Select a Reason. Mandatory field. Reason should be **Returned to Service
Enter a Comment
Enter an Expected Return to service date
Select the Black “Save” icon to save the entry

Helpful Hint Room availability grid will display room service 
history.
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View Tab (Visual Display of room status)
The View tab in Residential Room Management is a visual display of each bed and its availability. This is a view
only tab and no changes can be made. If students are assigned to the a bed and have photos in the system both
will display. 

Helpful Hint: Rooms displayed in RED font are currently 
suspended from use. 
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Getting Started

Double click > Modules > Double Click
Student Registration> Click Student Registration
Information 

In ClassMate users can assign students to residential 
rooms at the time of registration or after enrollment. 
To assign a student room at the time of registration 
perform the steps below.

Helpful Hint: 
This module should NOT be used for already enrolled students.

After registering a student using ClassMate Best Practices,  Select the BLUE Room Button
This will take you to the Registration Residency Management module. This module is used for students 
NOT yet enrolled.
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In the Registration Residency Management module users can 
quickly search to find residence rooms that have been assigned, 
those that are unassigned and then link registered students to 
rooms meeting their needs. This module is only for students NOT 
YET enrolled.

Filter Student Type by Assigned, Un-Assigned or both.
Select the Student Name you need to assign a room.

Once you have identified the student you will need to perform a 
search to identify the available rooms that have the required 
elements to meet the specific student need. 

Additionally, ClassMate will look at a students gender and only 
display available rooms/beds with like gender students. 

Helpful Hint: Enrolled students can have room assignments 
changed in Student Master.
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Registration Residency Mgmt: Assign Tab for students not yet enrolled

ClassMate users can assign registered student to rooms in this tab. The following search criteria are available.

Users must select at least one.

Location/Building Identifier Feature
Room Type Beds Mobile Equipment

Select at least 1 search criteria by clicking in the box to the left of the item. A check mark will display.

Select the BLUE Search button to create a list meeting the criteria indicated.

Helpful Hint: At least one search criteria must be entered when 
searching for rooms.
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Registration Residency Mgmt for students not yet enrolled
After a search has been performed and a list is generated, users will need to select the 
appropriate room for assignment. The color key legend is below:

Black Open
Blue No Open Beds
Green At Least One Open Bed
Red Occupied
Orange Suspended or Out of Service

Helpful Hint: Enrolled students can have room 
assignments changed in Student Master.
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Registration Residency Mgmt: Assign Tab for students not yet enrolled

Assigning or Pre-Assigning a room to a student in registration

Select at building with open beds (Green=At least one open bed)

Select a Black open bed
Select the *Assignment Date (Mandatory)
Select an *Assignment Reason (Mandatory)
Select an Unassignment Date (if known)
Enter a Comment (Optional) 
Select the Blue Assign Button

Helpful Hint: At least one search criteria must be entered when 
searching for rooms.
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Registration Residency Mgmt: Un-Assign Tab for students not yet enrolled

Un-Assign a room or update an expected 

un-assignment date:

Select the desired location from the drop down 
menu
Filter students by “Assigned”, “Unassigned” 
status or select “Both”
Select Student Name
Select the *Un-Assignment Date 
(Mandatory)
Select the Reason (Mandatory)
Enter a Comment (Optional)
Select the Blue Assign Button

Helpful Hint: Remember this module is to unassign students NOT Yet 
enrolled.
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Registration Residency Mgmt: History Tab for students not yet enrolled

Un-Assign a room or update an expected un-assignment date:

Select the desired location from the drop down 
menu
Filter students by Assigned, Unassigned
status or select Both
Select Student Name

On the history tab users can view a historical listing of all student room assignments, related dates and 
reasons. This is a “read only” module. Any changes must be made on the un-assign tab. 

Helpful Hint: The history tab is “read only.”
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Residency Management
The Residency Management module provides all the same functionality as the Registration Residency
Management module but is ONLY used for ENROLLED students and has additional functionality allowing for
Temporary room interruptions.

The following can be performed in the Residency Management module for enrolled students only.

Enrolled Student Room Assignments 
Enrolled Student Room Un-Assignment 
Enrolled Student Temporary Interruptions 
Enrolled Student Room History 

Helpful Hint: If you need to Assign or Pre-Assign a room to a student not yet enrolled or 
only registered, use the Registration Residency Mgmt. module.

Getting Started

Double click > Modules > Double Click
Student Enrollment> Click Residency Management



Residential Rooms Assignment

20

Residency Management: Assign, UnAssign & History Tab for currently Enrolled students

In the  Assign, Un-Assign & History modules users can follow the same procedures for use as described previously
in the Registration Residency steps with the exception on the Temporary Interruption Tab.

Helpful Hint: This  module is only for students currently enrolled. 
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Residency Management: Temporary Interruption Tab for currently Enrolled students

Any temporary interruption  to an enrolled student room assignment must be logged so users have an accurate
understanding of students in  residence. 

Select the desired location from the 
drop down menu
Filter students by Assigned, 
Unassigned status or select Both
Select Student Name
Enter the Interruption Date
Enter the Expected Return Date
Select a Reason from the drop down 
menu
Enter any relevant Comment(s)
Select the Blue Interrupt button

Helpful Hint: Users MUST re-instate a student upon their arrival back in 
the residence.
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Residency Management: Temporary Interruption Tab for currently Enrolled students

Re-instating a student after an interruption is vital to ensure accurate record keeping. Any temporary interruption 
Previously logged must be reinstated upon the students return. 

Select the desired location from the 
drop down menu
Filter students by Assigned, 
Unassigned status or select Both
Select Student Name
Select the Interruption by clicking in the 
box to the left
Enter the Reinstate Date
Select a Reason from the drop down 
menu
Enter any relevant Comment(s)
Select the Blue Reinstate button

Helpful Hint: Student can only have 1 active interruption at any given 
time.
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Residency Management: History Tab for currently Enrolled students

All student residency assignments, interruptions and  re-instatements. The items list in order of assignment 
date and then room interruptions by date. For example, student room assignments will list first in date order 
then any interruptions will list in date order. This is a read only modules. No changes can be made in this 
module.

Using the Edit Menu location along the top of the screen, several attendance options will display. They 
include:

Items in RED:   Unassigned 
Items in BLACK: Assigned
Items in GREEN: End of a temporary Interruption (eventually ALL interruptions should be green, 

meaning they have ended)
Items in BLUE: Interruption currently underway
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Attendance Reporting

System Administrator > Residency Codes List Report 
Lists all Residency Codes in entered into ClassMate 

Base Data Information > Available Bed List Reports  
Lists any and all available beds; only rooms with available beds 
will appear on report 

Base Data Information > Occupied Bed List Report 
Provides student room/ bed assignments, including occupancy 
status 

Base Data Information > Residency Room List Report 
Provides a room edit list Base Data Information > Residential 
Room History Reports on room history based on availability and 
service 

Base Data Information > Residential Room View 
Report 
Displays beds with student names and photos (if available) 

Student Registration > Registration Student Room List 
Report 
Lists room pre-assignments by student, including Building, Room 
ID, Bed number and Location Student 

Student Enrollment > Enrolled Student Room List 
Report lists room assignments by student, including Building, 
Room ID, Bed number and Location
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